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Error messaged denied by relay authentication

Issue

After successfully registering and obtaining an EXO API key you may receive the following error message when try to login:

{"Message":"Access denied by relay authentication provider [JWTAuthenticationProvider]."}

It will appear to be prompting for authentication for the server https://exo.api.myob.com:433.

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Causes:

There are two broad categories of this error:

1) The API Provider service is not started.

2) The Username/Password in use on the request does not match the identifiers encoded in the ExoToken.

Resolution

Firstly check that the headers in the request are all correct, but usually, this issue indicates that the username and password are a mismatch between the version of EXO used to generate the token and the actual provider service.

Make sure that the API Service is Started in the Windows Services list. If the headers are correct, the most common cause of problems is that the service is stopped.

Uninstall the current version on the machine and install it afresh with the latest version of the EXO API.

 

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